+7 (495) 215-5316

info@appropio.com

ул. Заозерная, 8

196084, Санкт-Петербург

09:00 - 19:00

сб.,вс. - выходные

Nuget.org – версии пакетов

 Этапы создания    
< Назад

 

Ниже перечисленных актуальные версии Nuget-пакетов, необходимые для настройки базовой версии приложения, которые необходимо добавлять при сборке каждого нового проекта.


Для iOS-приложения:

  • MvvmCross version=”5.7.0″
  • MvvmCross.Plugin.DownloadCache version=”5.7.0″
  • MvvmCross.Plugin.File version=”5.7.0″
  • MvvmCross.Plugin.Json version=”5.7.0″
  • MvvmCross.Plugin.Messenger version=”5.7.0″
  • MvvmCross.Plugin.Network version=”5.7.0″
  • MvvmCross.Plugin.Visibility version=”5.7.0″
  • Newtonsoft.Json version=”11.0.2″
  • modernhttpclient version=”2.4.2″
  • Microsoft.AppCenter version=”1.9.0″
  • Microsoft.AppCenter.Analytics version=”1.9.0″
  • Microsoft.AppCenter.Crashes version=”1.9.0″
  • Realm version=”3.2.1″
  • Xam.Plugin.ExternalMaps version=”4.0.1″
  • Xam.Plugin.Geolocator version=”4.5.0.6″
  • Xam.Plugins.Messaging version=”5.2.0″
  • Xam.Plugins.Settings version=”3.1.1″
  • Plugin.Permissions version=”3.0.0.12″
  • Plugin.Share version=”7.1.1″

Для Android-приложения:

  • MvvmCross version=”5.7.0″
  • MvvmCross.Plugin.DownloadCache version=”5.7.0″
  • MvvmCross.Plugin.File version=”5.7.0″
  • MvvmCross.Plugin.Json version=”5.7.0″
  • MvvmCross.Plugin.Messenger version=”5.7.0″
  • MvvmCross.Plugin.Network version=”5.7.0″
  • MvvmCross.Plugin.Visibility version=”5.7.0″
  • MvvmCross.Droid.Support.V7.RecyclerView version=”5.7.0″
  • MvvmCross.Droid.Support.Design version=”5.7.0″
  • MvvmCross.Droid.Support.V7.AppCompat version=”5.7.0″
  • Newtonsoft.Json version=”11.0.2″
  • Microsoft.AppCenter version=”1.9.0″
  • Microsoft.AppCenter.Analytics version=”1.9.0″
  • Microsoft.AppCenter.Crashes version=”1.9.0″
  • Realm version=”3.2.1″
  • Xam.Plugin.ExternalMaps version=”4.0.1″
  • Xam.Plugin.Geolocator version=”4.5.0.6″
  • Xam.Plugins.Messaging version=”5.2.0″
  • Xam.Plugins.Settings version=”3.1.1″
  • Plugin.CurrentActivity version=”2.1.0.4″
  • Plugin.Permissions version=”3.0.0.12″
  • Plugin.Share version=”7.1.1″
  • Glide.Xamarin version=”4.1.1″
  • Xamarin.GooglePlayServices.Maps version=”60.1142.1″
  • Xamarin.Android.Support.Constraint.Layout version=”1.1.2″
  • Xamarin.Android.Support.v7.CardView version=”27.0.2.1″

Общие пакеты, которые должны присутствовать как в iOS, так и в Android:

  • Microsoft.CSharp 4.4.1
  • Microsoft.NETCore.Platforms 2.0.1
  • NETStandard.Library 2.0.1

Следует учесть указанные версии пакетов, так как nuget.org может предоставить более свежие версии, однако важно использовать именно указанные выше.